[Ovmsdev] Duktape heap memory management

Craig Leres leres at xse.com
Sun Sep 5 09:45:28 HKT 2021

On 9/4/21 5:47 PM, Mark Webb-Johnson wrote:
> Regarding GPS lock, check AT+GPSAUTO? It should be disabled (0). If not, do a AT&F, then AT&W, and reboot. I suspect this may be a fault in simcom firmware / production with modules delivered not at factory defaults; as one of my two test modules was showing GPSAUTO 1, while a AT&F factory reset put it back to 0. I still haven’t worked around that in the 3.3 firmware driver yet (problem being we can’t configure the GPS while it is running, and GPSAUTO=1 starts the GPS on startup).

Helpful; after figuring out AT+GPSAUTO? -> AT+CGPSAUTO?, it was indeed 
enabled, and factory defaults+reboot fixed it.

Running with "log level verbose cellular" and looking at the SIM7600 AT 
command manual I see  the module doesn't seem to know what time it is 

     D (554006) cellular: mux-tx #3: AT+CREG?;+CCLK?;+CSQ;+COPS?
     D (554016) cellular: mux-rx-line #3: +CREG: 1,2
     D (554026) cellular: mux-rx-line #3: +CCLK: "80/04/01,02:10:04"
     D (554026) cellular: mux-rx-line #3: +CSQ: 99,99
     D (554026) cellular: mux-rx-line #3: +COPS: 0

Perhaps related to not being registered. I'm not making much sense of 
the others and scanning the pdf I don't see anything else that might be 

Something I can try without much effort is to swap in my spare SIM5380 
modem, that might reveal some other issue with my setup.

Regarding how to deal with the GPSAUTO=1 problem, what comes to mind 
would be a button on the cellular page that says "click here to fix the 
GPS and reboot". And I guess I've never used the guided setup but it 
could detect/fix this too.

Nice work on the simcom rework; if I can get this working I'd seriously 
think about moving the SIM7600 to one of my cars.


More information about the OvmsDev mailing list