[Ovmsdev] 3.2.018 release

Craig Leres leres at xse.com
Fri Nov 19 06:19:10 HKT 2021

On 11/18/21 13:32, Michael Balzer wrote:
> there was no change to the RTC or IRAM sections lately. Maybe somehow 
> your linker definition got messed up?

"git status" doesn't show any modified files in my copy of the tree. And 
I don't see any changes to my toolchain, looks like the last time I 
updated it was in July.

The only shared libraries the toolchain ld uses are libz and libc from 
the base os (not updated in more than a year).

The amount of overflow seems unreasonably large?

RTC_SLOW segment data does not fit.
region `iram0_0_seg' overflowed by 2172504 bytes
region `rtc_slow_seg' overflowed by 33681 bytes

2172504 bytes is over 2MB?!?!

I tried reverting to ~Oct 29th but I get the same errors so clearly 
something is recently wrong with my build environment.

I found this:


And tried running idf_size.py:

     ice 34 % python $IDF_PATH/tools/idf_size.py build/ovms3.map
     load: 0.09  cmd: python3.8 85307 [running] 3.59r 3.57u 0.00s 29% 13616k
     load: 0.45  cmd: python3.8 85307 [running] 12.20r 12.18u 0.00s 73% 
     Total sizes:
      DRAM .data size:       0 bytes
      DRAM .bss  size:       0 bytes
     Used static DRAM:       0 bytes ( 180736 available, 0.0% used)
     Used static IRAM:   16775 bytes ( 114297 available, 12.8% used)
           Flash code:       0 bytes
         Flash rodata:   64388 bytes
     Total image size:~  81163 bytes (.bin may be padded larger)

The end of that github issue points to changes in idf_size, could this 
be a python issue? Maybe python packages have been updated on this box 
since my last  build at the end of October.

Another seemingly related thread:


     "I check the components size. And you can see in the log, program
     uses the 0.8% of IRAM then how should the IRAM memory region

This feels like broken math somewhere.


More information about the OvmsDev mailing list