[Ovmsdev] GPS theft alert

Michael Balzer dexter at expeedo.de
Mon Mar 1 15:39:17 HKT 2021


when connecting my bench module to my Arduino CAN shield, I need to add 
a terminal resistor in between. Did you try that?

You could then test if can2 & can3 are also affected. can1 is the 
internal bus of the ESP32 module, can2/3 are external MCP2515 buses 
accessed via SPI.

If it's can1 only, you could try running some CAN tester using the 
latest esp-idf driver. Maybe there are differences between the hardware 
revisions, revision 1 has some hardware bugs in the CAN controller as well.

 From a first look into the current esp-idf master, there is now a HAL 
for CAN (now called TWAI "two-way async interface" for whatever reason), 
and there seem to be some differences between the revisions. But AFAICT 
only minor ones:



Am 01.03.21 um 02:28 schrieb Craig Leres:
> Michael, thanks for pointers on sd card logging. Meanwhile I've 
> figured out my problem is basic and the theft alert is just a symptom.
> Last week I get sd logging configured and the first time I drove I got 
> to my destination (slightly more than 500m away) and happened to 
> notice that the ovms ios app showed my car had been parked for > 20 
> days... Thanks to the persistent metrics feature I didn't notice but 
> it appears that my modules haven't communicated with my cars since 
> about the end of January; for example the fuel gauge was at 1/4 but 
> the app showed 87%. So in fact my theft alert problem is that v.e.on 
> is *never* true.
> Today I did some debugging. I tried running older builds (I keep an 
> archive of everything I actually run) and even went back to the 
> 3.2.015 and 3.2.014 factory builds but when the car is running I don't 
> see any metrics getting updated. I did see a can bus error message but 
> it looks like I didn't capture it.
> At this point I transitioned to the bench and my dev ovms module. I 
> have a raspberry pi 2 that has a can shield I've used for other 
> projects. I verified that candump/cansend could exchange canbus frames 
> with a prototype arduino project I had sitting around and then plugged 
> it into ovms module. I've appended my test session; I only tried 
> sending from ovms with the pi running "candump any".
> Given that all three of my modules have canbus issues and the fact 
> that this problem started around the time I swapped esp32 modules I 
> think it's clear that I have a hardware problem related to the new 
> esp32 modules. And it's probably not a bad solder joint as I inspected 
> them with the stereo microscope (and it's not likely I'd botch the 
> same pin(s) on all three modules).
> Unfortunately I don't have much debugging left this weekend but what 
> do you suggest for my next move?
>         Craig
> Welcome to the Open Vehicle Monitoring System (OVMS) - SSH Console
> Firmware: 3.2.015-718-g3f74c233/ota_0/main
> Hardware: OVMS WIFI BLE BT cores=2 rev=ESP32/3
> OVMS# vehicle status
> Vehicle module 'Empty Vehicle' (code NONE) loaded and running
> OVMS# can list
> can1: Off/1000000 dbc none
> can2: Off/1000000 dbc none
> can3: Off/1000000 dbc none
> OVMS# can can1 start active 500000
> Can bus can1 started in mode active at speed 500000bps
> OVMS# can list
> can1: Active/500000 dbc none
> can2: Off/1000000 dbc none
> can3: Off/1000000 dbc none
> OVMS# log level verbose can
> Logging level for can set to verbose
> OVMS# can log start vfs crtd /sd/can.crtd
> CAN logging to VFS active: Type:vfs Format:crtd(discard) Filter:off 
> Vehicle:NONE Path:/sd/can.crtd
> OVMS# can can1 tx standard 87 DEAD
> E (982009) can: can1: intr=1 rxpkt=0 txpkt=0 errflags=0x8000a2 rxerr=1 
> txerr=0 rxovr=0 txovr=0 txdelay=0 txfail=0 wdgreset=0 errreset=0
> E (982009) can: can1: intr=11 rxpkt=0 txpkt=0 errflags=0x8040a2 
> rxerr=100 txerr=0 rxovr=0 txovr=0 txdelay=0 txfail=0 wdgreset=0 
> errreset=0
> E (982009) can: can1: intr=15 rxpkt=0 txpkt=0 errflags=0x204000 
> rxerr=135 txerr=0 rxovr=0 txovr=0 txdelay=0 txfail=0 wdgreset=0 
> errreset=0
> E (982009) can: can1: intr=19 rxpkt=0 txpkt=0 errflags=0x8040a2 
> rxerr=135 txerr=0 rxovr=0 txovr=0 txdelay=0 txfail=0 wdgreset=0 
> errreset=0

Michael Balzer * Helkenberger Weg 9 * D-58256 Ennepetal
Fon 02333 / 833 5735 * Handy 0176 / 206 989 26

-------------- next part --------------
A non-text attachment was scrubbed...
Name: OpenPGP_signature
Type: application/pgp-signature
Size: 203 bytes
Desc: OpenPGP digital signature
URL: <http://lists.openvehicles.com/pipermail/ovmsdev/attachments/20210301/18321764/attachment.sig>

More information about the OvmsDev mailing list