[Ovmsdev] Refactoring MODEM/SIMCOM for v3.3

Mark Webb-Johnson mark at webb-johnson.net
Mon Aug 31 14:34:56 HKT 2020


I haven’t completed the SIM7600 and SIM7000 drivers yet. Apart from a few minor command differences, they both seem to expose a bug in our MUX driver which sometimes causes a crash (particularly in areas of poor cellular connectivity). I’l guessing just some unknown / unhandled frame type.

Model recognition should work now. But the power cycle for these modems is tricky.

If you want to have a look at the SIM7600 driver, that is fine by me. I won’t have time to look at it for a couple of weeks I think (trying to bring across all my old work on the plugin system first). I am really just trying to get the low level refactoring done at the moment (which is pretty much done now). The code is in simcom_7600.cpp, and is very small. I remember the big init command  has some unrecognised stuff in it, but haven’t had time to remove/fix them yet:


The modem can now be put into ‘power modem devel’ mode, where you can simply ‘cellular tx AT…’ commands to it. Send each of the above, one by one, and you’ll find the incorrect ones. I seem to remember there were two.

Regards, Mark.

> On 31 Aug 2020, at 11:51 AM, Craig Leres <leres at xse.com> wrote:
> On 2020-08-30 00:20, Mark Webb-Johnson wrote:
>> The initial implementation of this work is in branch for-v3.3, in GitHub. That branch can be used for the upcoming 3.3 release, including potentially breaking changes.
>> I’d appreciate any feedback. For the SIM5360, the behaviour should be unchanged from the current implementation (except some improvements to edge cases and control logic). The major user visible change is from ’simcom’ to ‘modem’ for the console commands.
> I built and flashed this version on my dev module and was able to register on the cell network and get a gps fix (sim5360).
> I swapped in my sim7600 modem board, switched the 500 mA power adapter for a 1.5A version and booted. Very shortly after booting the /status page showed "Unrecognised command" for the modem. But "cellular" showed this:
>    OVMS# cell
>    MODEM Status
>      Model: SIM7600
>      Network Registration: Searching
>        Provider:
>        Signal: 0 dBm
>      State: NetWait
>      Mux: Status up
>      PPP: Not running
>      GPS: Connected on channel: #1
> I was using the serial console and notice that "cell" command worked without enable but "location status" (still) required enable mode.
> I don't have a lot of confidence in my cell antenna setup, the best I can say about it is it worked with the sim5360 and it's the same as what I've been using my my Corvette (the gm oem onstar windshield antenna with separate cell and gps connections). I dug out a pair of fasttech antennas and used the web page to cycle power on the modem. After this point the module was unable to identify the module. I tried rebooting and that didn't help. I cycled power and it was able to id the simcom again but still no network registration or gps. The next time I did a warm reboot the MODEM Status Model was again stuck on auto.
> I don't have any time left this weekend for serious debugging but I'm game if there are simple things you'd like me to try.
> 		Craig

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openvehicles.com/pipermail/ovmsdev/attachments/20200831/32b051bc/attachment.htm>

More information about the OvmsDev mailing list