[Ovmsdev] Script engine not working?

Soko ovms at soko.cc
Sat Aug 1 16:51:50 HKT 2020

Hey guys,

I've tried to use the script engine and created some files. But when I 
run the files nothing happens. No output at all. Here is my webc onsole 

OVMS# vfs ls /store
[DIR]     01-Jan-1980 00:00  ovms_config/
[DIR]     01-Aug-2020 10:12  scripts/
OVMS# vfs ls /store/scripts
      35   01-Aug-2020 10:27  vfstest.bat
      35   01-Aug-2020 10:29  vfstest.js
      35   01-Aug-2020 10:29  vfstest
      35   01-Aug-2020 10:31  vfstest.cm
      35   01-Aug-2020 10:31  vfstest.cmd
      35   01-Aug-2020 10:33  vfstest.py
OVMS# vfs head /store/scripts/vfstest
vfs ls /store
vfs ls /store/scripts
OVMS# script run /store/scripts/vfstest

I would expect the output of the two first commands after running the 
script! What am I doing wrong here? I've also tried some different file 
extensions as you can see. I've also had a look into the source (static 
void script_ovms(...)) to find the special file extension that is 
needed. But apparently everything besides .js is handled as command script.


PS: I've created the files via the web editor. Do they need any special 
termination character after each line?

More information about the OvmsDev mailing list