[Ovmsdev] <enter> not working with vfs edit?

Stephen Casner casner at acm.org
Fri Jan 12 14:04:01 HKT 2018


I put in a \r to \n translation in the async console similar to what
has been present all along in the telnet and ssh consoles.  I made
this change because in the esp-idf v3.0 there is a new behavior for
stdin line endings.  In the config there are additional lines to choos
the stdin line ending:


This defaulted to CR which resulted in the async console never seeing
a newline input so it was not possible to execute commands.  It did
not matter whether Ctrl-J or Ctrl-M is pushed on the keyboard, still
the character coming through was CR.

Unfortunately, changing the config to LF or CRLF did not seem to make
any difference.  It appears that the compiled code does not change
with this parameter, so my guess is that it is supposed to affect the
behavior of the python code.  I believe the python code is where the
character translation is occurring because when I tried "make
simple_monitor" then it looks like both CR and LF were delivered to
the console.  I tried my own console program that I wrote a while ago;
it translates Enter to newline before sending it through, so then the
console received the newline that it wants and responded properly.

After discussing with Mark, we agree to fix the problem by having the
async console translat CR to LF.  You could argue that this was not
fixing the problem in the right place since the change in behavior
that prompted the change was apparently in the python monitor program.

                                                        -- Steve

On Thu, 11 Jan 2018, Greg D. wrote:

> Is anyone else having trouble with the vfs editor?  I can't seem to
> enter a newline anymore.  The status line at the bottom complains of an
> unknown command 10 (presumably control-J).  If I try an explicit
> control-M, it says the same.
> Did I fat-finger something in my config (I removed SSH, Telnet, and
> several other items to save RAM recently), or did something else
> change?  This is with two different terminals - make monitor on the
> development laptop, and putty on my in-car Raspberry Pi.
> Greg
> _______________________________________________
> OvmsDev mailing list
> OvmsDev at lists.teslaclub.hk
> http://lists.teslaclub.hk/mailman/listinfo/ovmsdev

More information about the OvmsDev mailing list