[Ovmsdev] /store gone

Greg D. gregd2350 at gmail.com
Sun Feb 18 03:58:53 HKT 2018

Since there hasn't been a huge cry for more info about my module, how
does one safely (without bricking potential) re-initialize the flash?  I
seem to recall there was a button pressing sequence, but can't find the


Greg D. wrote:
> Not the recovery, the troubleshooting.  Didn't want to write to it if
> there were any tea leaves that we needed to analyze, though come to
> think of it, the (empty) ovms_config directory was written there
> already, so... 
> Tried creating an obd2ecu map item, and now ovms_config has a file in
> it, and the file contains the map.  So, writing and reading work, and
> they survive a reboot.
> So, wipe it?  Any last tea leaves to sift through?
> What is the safest way to put flash back to a good state (without having
> access to a programmer!)?
> Greg
> Stephen Casner wrote:
>> I get the same error message if I try "vfs cat /store/scripts" (which
>> is a directory), so I don't think that message indicates anything
>> worse for you.  If the recovery approach is to wipe flash, what harm
>> could there be in trying to write something in the config?
>>                                                         -- Steve
>> On Fri, 16 Feb 2018, Greg D. wrote:
>>> That would have helped.  Also, shouldn't a 'stat' of it return something
>>> useful?  That error about not being able to open it leaves me wondering
>>> about what is safe to do at this point.
>>> Greg
>>> Stephen Casner wrote:
>>>> On Sat, 17 Feb 2018, Mark Webb-Johnson wrote:
>>>>> Ovms_config is a directory. Don't think you can cat it.
>>>> Oh, right.  Perhaps vfs ls should add a trailing '/'?
>>>>                                                         -- Steve
>> _______________________________________________
>> OvmsDev mailing list
>> OvmsDev at lists.teslaclub.hk
>> http://lists.teslaclub.hk/mailman/listinfo/ovmsdev

More information about the OvmsDev mailing list