[Ovmsdev] SIM808 not communicating

Mark Webb-Johnson mark at webb-johnson.net
Mon Jul 25 16:17:40 HKT 2016

If the GPRS settings are not working, and GPRS is enabled, sometimes the errors and repeated retries on GPRS interfere with the SMS message reception.

I suggest to try with the GSM/GPRS switch set to GSM only and see if SMS then works.

Regards, Mark

> On 22 Jul 2016, at 10:03 PM, Tom Parker <tom at carrott.org> wrote:
>> On 22/07/16 21:17, Tom Parker wrote:
>>> On 22/07/16 18:38, Michael Balzer wrote:
>>> You can use the diag mode to send an SMS manually. Note: the 808 does not echo LF, only CR.
>> I'll try that out.
> I couldn't make SMS work while interactively typing the AT commands. I did manage to send "null" to my phone a few types even though the body of the message was not the letters n u l l nor empty, but most of the messages failed to send.
> I tried a different SIM card, one for the Vodafone New Zealand network and this worked fine. The SIM card that can't send text messages is a 2degrees SIM card.
> I also found why GPRS wasn't working, I had the wrong username for my ovms server account! I after I corrected that username GPRS works on the 2degrees network as well (but SMS still doesn't work).
> So it would seem the SIM808 isn't fully compatible with the 2degrees network in New Zealand?
> _______________________________________________
> OvmsDev mailing list
> OvmsDev at lists.teslaclub.hk
> http://lists.teslaclub.hk/mailman/listinfo/ovmsdev

More information about the OvmsDev mailing list