[Ovmsdev] CFG commands on RT_Production

Michael Balzer dexter at expeedo.de
Tue Sep 23 02:02:47 HKT 2014

Hi Julien,

welcome :)

Am 22.09.2014 um 16:55 schrieb Julien NOZAIS:
> *MSG commands*
> My current situation is that I have upgraded my OVMS module to 2.6.5 
> firmware with the .hex file provided on GitHub. I have also 
> successfully connected to the module via SMS commands and Android App. 
> Most of the basic commands that I tried worked.
> I say 'most', because I have set the #15 'write' bit to '1' and 
> cleared the #14 bit as well. However, I don't seem to be able to send 
> CFG commands via SMS (such as CFG SPEED <speed> for example) in the 
> way that the twizy manual describes it. All I get are push 
> notifications forwarding my SMS to the app. Is there something I'm 
> missing? :(

Yes. That's having read the last page of the manual and/or having 
browsed through this list's archive... ;)

The Github hex files are missing the SEVCON functions. You need to 
download the latest hex release from the german forum or compile yourself.

To compile yourself you need to define these (and only these) compiler 


...and you need to manually exclude source files "acc.c", "logging.c" 
and all other "vehicle*.c" from the build, because otherwise...

> > Error - section '.romdata_net_msg.o' can not fit the section. 
> Section '.romdata_net_msg.o' length=0x000000a8
... this will happen ;)

Just use the context menu "properties" on the files to exclude them.

> *DIAG communication*
> Probably noob error: I tried connecting through the DIAG port with 
> minicom. I set minicom to 9600 Bds / 8N1, as specified in the 
> developers documentation, but had no success. I think that I'm closed 
> since since I received data, but it was just gibberish encoding 
> errors. Since these errors are often caused by a wrong baud setting, I 
> tried different baud values without success. I hope somebody can point 
> out something that I could have missed. I have read the manual, but, 
> well... you never know.

Be sure to also disable any flow control. Depending on your serial 
adapter, another parameter init and/or hardware reconnect may be 
necessary. Also make sure your serial device is writable by your login, 
to be sure launch minicom as root.

> I look forward to reading from you !

I look forward to reading about your project :)


Michael Balzer * Paradestr. 8 * D-42107 Wuppertal
Fon 0202 / 272 2201 * Handy 0176 / 206 989 26

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openvehicles.com/pipermail/ovmsdev/attachments/20140922/92862032/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: dexter.vcf
Type: text/x-vcard
Size: 206 bytes
Desc: not available
URL: <http://lists.openvehicles.com/pipermail/ovmsdev/attachments/20140922/92862032/attachment-0002.vcf>

More information about the OvmsDev mailing list