<html><head><meta http-equiv="Content-Type" content="text/html; charset=utf-8"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; line-break: after-white-space;" class="">Nice find. That explains a lot of auto-recovered DNS issues over the past few months.<div class=""><br class=""></div><div class="">Regards, Mark.</div><div class=""><br class=""><div><br class=""><blockquote type="cite" class=""><div class="">On 16 Jun 2018, at 4:30 PM, Michael Balzer <<a href="mailto:dexter@expeedo.de" class="">dexter@expeedo.de</a>> wrote:</div><br class="Apple-interchange-newline"><div class="">
  
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" class="">
  
  <div text="#000000" bgcolor="#FFFFFF" class="">
    Got it:<br class="">
<a class="moz-txt-link-freetext" href="https://github.com/openvehicles/Open-Vehicle-Monitoring-System-3/commit/a4a70b59eb5038a9c374f0b70e4b8d13e9103ea4">https://github.com/openvehicles/Open-Vehicle-Monitoring-System-3/commit/a4a70b59eb5038a9c374f0b70e4b8d13e9103ea4</a><br class="">
    <br class="">
    This may have been responsible for some other DNS issues in the
    past.<br class="">
    <br class="">
    Regards,<br class="">
    Michael<br class="">
    <br class="">
    <br class="">
    <div class="moz-cite-prefix">Am 15.06.2018 um 23:52 schrieb Michael
      Balzer:<br class="">
    </div>
    <blockquote type="cite" cite="mid:884f013f-fdf3-a4c3-2317-33a2dd10bcbc@expeedo.de" class="">
      <meta http-equiv="Content-Type" content="text/html; charset=utf-8" class="">
      Answering my own question: yes, the bug has been introduced with
      commit c1f96e71dd51c44f9aeff9cf5940982b939a8b24, the SPIMEM
      rework.<br class="">
      <br class="">
      Very strange‚Ķ<br class="">
      <br class="">
      <br class="">
      <div class="moz-cite-prefix">Am 15.06.2018 um 23:35 schrieb
        Michael Balzer:<br class="">
      </div>
      <blockquote type="cite" cite="mid:7f935a75-ca5b-783e-8abc-a8b65af6ea39@expeedo.de" class="">
        <meta http-equiv="content-type" content="text/html;
          charset=utf-8" class="">
        ‚Ķmanifesting in "ota status" and web firmware page not being
        able to show the latest version & info.<br class="">
        <br class="">
        It seems the error always comes on the web page.<br class="">
        <br class="">
        On "ota status" it normally only comes once, then successive
        "ota status" calls work. Loading the web page seems to restart
        the cycle.<br class="">
        <br class="">
        <blockquote class=""><tt class="">I (695311) webserver: HTTP GET /cfg/firmware</tt><br class="">
          <tt class="">W (695361) net: DNS lookup on <a href="http://ovms.dexters-web.de" class="">ovms.dexters-web.de</a> failed
            err=200</tt><br class="">
          <tt class="">D (695471) webserver: Serve /cfg/firmware: 9940 bytes
            used, 4171640 free</tt><br class="">
          <tt class="">OVMS# ota status </tt><br class="">
          <tt class="">Running partition: ota_1</tt><br class="">
          <tt class="">Boot partition:    ota_1</tt><br class="">
          <tt class="">Firmware:          3.1.006-44-gd3fcb8b-dirty/ota_1/edge
            (build idf ovms-3.1.006-2-g1a1a544a Jun 13 2018 23:28:20)</tt><br class="">
          <tt class="">W (698871) net: DNS lookup on <a href="http://ovms.dexters-web.de" class="">ovms.dexters-web.de</a> failed
            err=200</tt><br class="">
          <tt class="">OVMS# ota status </tt><br class="">
          <tt class="">Running partition: ota_1</tt><br class="">
          <tt class="">Boot partition:    ota_1</tt><br class="">
          <tt class="">Firmware:          3.1.006-44-gd3fcb8b-dirty/ota_1/edge
            (build idf ovms-3.1.006-2-g1a1a544a Jun 13 2018 23:28:20)</tt><br class="">
          <tt class="">Server Available:  3.1.006-45-gd8220ef (is newer)</tt><br class="">
          <br class="">
          <tt class="">OTA bleeding edge developer build Wed Jun 13 23:54:42 CEST
            2018</tt><br class="">
          <tt class="">See ovms3.log for details</tt><br class="">
          <br class="">
          <tt class="">d8220ef - Web UI: simplified time zone region selection
            (vehicle config)</tt><br class="">
          <tt class="">d3fcb8b esp32can: Try draining rx fifo in main
            ESP32CAN_rxframe function</tt><br class="">
        </blockquote>
        <br class="">
        This is brand new, has been working flawlessly before. Mark, can
        this be caused by the aggressive SPIMEM rework?<br class="">
        <br class="">
        Regards,<br class="">
        Michael<br class="">
        <br class="">
        <pre class="moz-signature" cols="160">-- 
Michael Balzer * Helkenberger Weg 9 * D-58256 Ennepetal
Fon 02333 / 833 5735 * Handy 0176 / 206 989 26
</pre>
        <!--'"--><br class="">
        <fieldset class="mimeAttachmentHeader"></fieldset>
        <br class="">
        <pre wrap="" class="">_______________________________________________
OvmsDev mailing list
<a class="moz-txt-link-abbreviated" href="mailto:OvmsDev@lists.openvehicles.com" moz-do-not-send="true">OvmsDev@lists.openvehicles.com</a>
<a class="moz-txt-link-freetext" href="http://lists.openvehicles.com/mailman/listinfo/ovmsdev" moz-do-not-send="true">http://lists.openvehicles.com/mailman/listinfo/ovmsdev</a>
</pre>
      </blockquote>
      <br class="">
      <pre class="moz-signature" cols="160">-- 
Michael Balzer * Helkenberger Weg 9 * D-58256 Ennepetal
Fon 02333 / 833 5735 * Handy 0176 / 206 989 26
</pre>
      <!--'"--><br class="">
      <fieldset class="mimeAttachmentHeader"></fieldset>
      <br class="">
      <pre wrap="" class="">_______________________________________________
OvmsDev mailing list
<a class="moz-txt-link-abbreviated" href="mailto:OvmsDev@lists.openvehicles.com">OvmsDev@lists.openvehicles.com</a>
<a class="moz-txt-link-freetext" href="http://lists.openvehicles.com/mailman/listinfo/ovmsdev">http://lists.openvehicles.com/mailman/listinfo/ovmsdev</a>
</pre>
    </blockquote>
    <br class="">
    <pre class="moz-signature" cols="160">-- 
Michael Balzer * Helkenberger Weg 9 * D-58256 Ennepetal
Fon 02333 / 833 5735 * Handy 0176 / 206 989 26
</pre>
  </div>

_______________________________________________<br class="">OvmsDev mailing list<br class=""><a href="mailto:OvmsDev@lists.openvehicles.com" class="">OvmsDev@lists.openvehicles.com</a><br class="">http://lists.openvehicles.com/mailman/listinfo/ovmsdev<br class=""></div></blockquote></div><br class=""></div></body></html>