[Ovmsdev] Urgent TLS root certificate issue (Let's Encrypt)

Mark Webb-Johnson mark at webb-johnson.net
Tue Oct 12 10:23:59 HKT 2021


Yes, it does seem that WOLFSSL_ALT_CERT_CHAINS is the correct solution for this.

> Mark, how soon will v3.3 modules be available so I could have a usable
> bench unit?

The modules are in the certification lab now. Still targeting end of November, for certification, and sometime in December for first production batch. But that depends on the lab result. EM testing is always painful (and not really relevant to in-vehicle devices anyway, but a hurdle we must cross).

I can send you a 3.2 wifi unit if it helps? I have a few repaired from RMA returns.

Regards, Mark.

> On 10 Oct 2021, at 2:36 AM, Stephen Casner <casner at acm.org> wrote:
> On Wed, 29 Sep 2021, Michael Balzer wrote:
>> I tried WOLFSSL_ALT_CERT_CHAINS but only got crashes with that.
> This morning I found an issue thread for wolfssl that discusses the
> Let's Encrypt certificate problem and indicates that WolfSSL is not
> intending to make any changes:
> https://github.com/wolfSSL/wolfssl/issues/4443
> The answer in that thread is to build with SNI and
> WOLFSSL_ALT_CERT_CHAINS.  So that means the answer for us is that I
> need to figure out why that option causes a crash.  I remember that I
> tried that option without success when doing the porting work.  I need
> to refresh my memory as to what was the problem.
> Mark, how soon will v3.3 modules be available so I could have a usable
> bench unit?
>                                                        -- Steve
> _______________________________________________
> OvmsDev mailing list
> OvmsDev at lists.openvehicles.com
> http://lists.openvehicles.com/mailman/listinfo/ovmsdev

More information about the OvmsDev mailing list