[Ovmsdev] OVMS hang/crash

Stephen Casner casner at acm.org
Sat May 19 04:31:26 HKT 2018

I took a three-day road trip to Yosemite this week with the v3.0
module in the car.  It seemed to work fine, communicating over the
modem except for the spotty reception in the Yosemite Valley due to
the high stone cliffs.  But back at home, some time after I had
plugged in to start charging, the module stopped communicating via
modem or wifi.  I tried plugging in the USB cable to see what was
wrong, but the /dev/tty.SLAB_USBtoUART device did not get created on
my laptop so I could not see what went wrong.

At that point, I decided I needed to cycle power to reboot, then the
module came back up as verified via the home wifi, but the USB was
still not responding.  Now I have taken the module out of the car and
brought it in to connect to the laptop and USB is working again.  I
guess that must imply that the USB physical connection, although the
cable seemed solidly inserted while in the car.

I have had the module configured to go to gdb rather than reboot on
crashes since that was helpful for development, but I may need to
change that setting to use the module in the car.  On the other hand,
with small RAM of the v3.0 module I don't think I can afford to have
the SD card plugged in for logging, so being able to investigate
crashes via USB might be best for now if I can figure out why that
didn't work this morning.

                                                        -- Steve

More information about the OvmsDev mailing list