[Ovmsdev] v3 hardware disconnecting from v2 server

Tom Parker tom at carrott.org
Sun Mar 25 03:39:32 HKT 2018

On 25/03/18 02:41, Mark Webb-Johnson wrote:
> What do you mean by ‘disable and reactivate the SIM card’? How are you doing that?

I have access to Spark's m2m service which allows customers to 
deactivate and reactivate simcards. The deactivation is immediate, I can 
see the simcom reports it is disconnected and the ovms starts trying to 
reconnect. Last time I tried, when I reactivated, the simcom reconnected 
to the cell phone network but the ovms never re-established a ppp 
connection. I can send it sms messages and see them show up in the 
simcom logging so I know some things are working. I last tried this a 
couple of weeks ago, I'll try again tomorrow.

I have a range of devices on this service and some of the reconnect 
while other don't, so the ovms isn't the only one having trouble.

> The issue I was having was some task (I suspect lwip) gets messed up. Stopping the modem, trying to connect wifi, etc, all just locked up the async console. I think you had the same?

I've certainly had situations where doing simcom power off causes the 
async console to freeze, but I've only tried to do that after the 
cellular is has stopped working.

> Cellular connectivity should be a different issue. Maybe just can’t connect to the signal - but the logs should tell us more info. We can also directly issue AT commands when the modem is in that state to try to find out why.

Any advice on which commands to try when it's not connected?

More information about the OvmsDev mailing list