[Ovmsdev] Config store mount failure / reformatting

Craig Leres leres at xse.com
Thu Aug 23 14:37:28 HKT 2018

It took a number of tries but I have module back on my wifi. I'm pretty 
sure if you try to skip setting the module pw and go directly to joining 
the wifi network it never succeeds. I tried at least 3 times, was on my 
iphone and was doing copy-paste between 1Password and the fields in the 
browser and it never worked until I set the module id and passphrase to 
something temporary. I was trying to quickly get off of my iphone and 
back to where I could cut-n-paste in my desktop so I was trying to skip 
that step. If the plan is to disallow letting the user to quick-setup 
not set a password, then we shouldn't allow skipping this step.

Something I did do from my iphone was to switch firmware partitions to 
the one that had the ota 3.1.008 so that I wouldn't hose my config 
again. I think I got that right but I did something else wrong because 
when I got the module in my wifi I ended up losing my config one more 
time when I tried to upgrade to a newly built image. I'll do some more 
git-foo before trying that again...

It felt like the setup process gave up too easily and reset to the 
default ssid/passphrase of OVMS/OVMSinit. There's probably a fine 
balance here. I had usb/serial going during the process which was 
certainly more interesting than just waiting for things to 
timeout/errorout or work. But I was a little surprised that the setup 
process didn't let me pick the ssid from a list of locally available. 
It's certainly what I expected but maybe this was covered in some of the 
esp32 wifi threads I didn't read closely.

Anyway: Overall I'm happy to have tried out the new setup process.

On 8/22/18 8:49 PM, Mark Webb-Johnson wrote:
> I couldn’t get mine to work, so in the end just removed the esp-idf directory, and cloned again. Given enough Internet bandwidth, that seemed faster than messing around with git.

Attached sums up git for me.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: git.png
Type: image/png
Size: 62715 bytes
Desc: not available
URL: <http://lists.openvehicles.com/pipermail/ovmsdev/attachments/20180822/cb7d0b6d/attachment-0002.png>

More information about the OvmsDev mailing list