[Ovmsdev] Initial experience and Nissan Leaf updates (was: Turned off commenting on the OVMS v3 User Guide)

Robin O'Leary ovmsdev at caederus.org
Thu Apr 19 23:39:03 HKT 2018

On Mon, Apr 16, 2018 at 08:59:58PM +0800, Mark Webb-Johnson wrote:
> My server is now showing 14 v3.x modules connected (2 of which are mine):
> 1 running 3.1.003-41-gc299c84-dirty/ota_0/ro1

That would be me.  As a long-time follower of the project, but first-time
user of an actual OVMS device, I would say my "getting started" experience
was very good; mostly plusses, with few minuses (and some of those seemed
to go away later without my intervention):

+ OVMS unit plugged in to USB power.
- No obvious power/status LED (I've since spotted it inside).
+ Connected to OVMS access point using android phone.
- Tried to visit in phone's web browser (Firefox 55.0.2);
  it seemed to connect, but would only display a blank page.
+ Connected OK with 'ssh admin at'
+ Entered 'enable' and poked around with some wifi/network commands.
- Couldn't figure out how to set up wifi client ssid and password.
- google docs mentions 'config list wifi.ssid' but not how you add new ones.
- Tried 'wifi scan', which cut off my ssh connection.  Rebooted.

+ Connected to OVMS access point again, this time with a debian laptop.
+ Successfully visited in web browser (Firefox 52.3.0).
+ Changed password as prompted.
+ Added wifi client ssid and password.
- Took a while for me to find the option 'Autostart - Wifi mode:'
+ Set that to 'Access point + Client'; Save & reboot.
+ OVMS got an address as a wifi client in my network.
+ Successfully visited web page on new IP address.
- 'ssh admin at NEWIP' connects, but then immediately closes the connection.

+ Plugged module in to car (Nissan Leaf 2016).
+ Configured vehicle type etc.
+ Battery, range, odometer, temperature status updates.

+ Configured OVMSv2 server at api.openvehicles.com.
+ Module's web status says 'State: Connected'.
- Not sure how to tell if it's working at the server end.
+ Download and install android app.
- Server defaults to tmc.openvehicles.com (not api....)
- Not sure what to put for SMS/module password.
- Control - FEATURES, PARAMETERS both get stuck waiting for data.
  (they started working some time later).
+ Live values start showing up!

+ Set up account with https://hologram.io/
- google doc doesn't give URL
- Tried 'metric list m.net.mdm.iccid', but that just printed
  'm.net.mdm.iccid' (it started working some time later).
+ Activated SIM at https://dashboard.hologram.io/

+ ota update to 3.1.003 worked flawlessly

Since then, I got a development environment set up with remarkably
little trouble, and I've been adding some new metrics for the Nissan Leaf:
    * ms_v_bat_soh from 0x5b3[1]
    * ms_v_charge_temp from 0x54f[0] (this is actually inside temp)
    * ms_v_door_fl etc. from 0x60d[0]
    * ms_v_env_gear from 0x421[0]
    * ms_v_env_handbrake from 0x5c5[0] (was faked by vehicle_nissanleaf_car_on)
    * ms_v_env_headlights from 0x60d[0,1]
    * ms_v_env_on from 0x60d[1] (was faked by vehicle_nissanleaf_car_on)
    ...but continue to fake ms_v_env_awake by CAN activity of 0x284
    * ms_v_env_locked from 0x60d[2]
    * ms_v_inv_temp from 0x510[7]
    * ms_v_tpms_fl_p etc. from 0x385[2..5]
These all seem to be working nicely (at least, on my UK MY2015).

I have a few questions:

I would like to record the temperature inside the car, but I couldn't
see an appropriate metric (I've stuck it on ms_v_charge_temp for now).
Is there a better place for it?

What is the intent of ms_v_env_on?  It was previously set true when
certain CAN traffic was present and false after a period of inactivity.
I now set it to true when the car is in state "ready to drive".

A similar question goes for ms_v_env_awake.  I've left this doing the
CAN activity detection, which means it changes for minor things like
detecting a key-fob.

What is the process for contributing changes?  I am currently doing
my local work on the master branch cloned from github.

Even after upgrading the firmware to the latest from git, I still have
the problem with ssh connecting but then immediately dropping.  Is
there some debug option I should turn on to find out why?
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 181 bytes
Desc: Digital signature
URL: <http://lists.openvehicles.com/pipermail/ovmsdev/attachments/20180419/c55f3b6f/attachment-0002.sig>

More information about the OvmsDev mailing list