[Ovmsdev] Problem switching to Range mode charging (TR)

Greg D. gregd2350 at gmail.com
Sat Apr 7 13:37:20 HKT 2018

Hi Mark,

OVMSv3.0 is all I have.  The car had just finished a daily top-up about
10 minutes prior, and was sitting there fully charged at Standard.  Car
was asleep, not charging.  I just went into the app and changed the
charging mode from standard to range, and it happened.  Should I have
started a charge at Standard first, then changed the mode?  Also, why is
the charging current in the app only offered at 10 amps, regardless of mode?

When I do it from the VDS I just change the mode, and the charging kicks
in since it's low in that new context.  Amps stay at 24.


Mark Webb-Johnson wrote:
> Greg,
> That does sound worrying. Was this with OVMS v2 or v3 module?
> The commands sent is identical to that sent from the VDS.
> I presume that the car had ignition key off, and was plugged in and charging at the time? If not, can you provide more details regarding the exact state?
> Regards, Mark.
>> On 7 Apr 2018, at 12:05 PM, Greg D. <gregd2350 at gmail.com> wrote:
>> Curiosity (and nervousness) got the better of me, so I pulled the logs
>> now.  Error code in the log was #278, which is listed but with no
>> further information.
>> Oddly, the log also shows that the car was being driven for 24 seconds
>> during that time (presume while the error was on the VDS).  Zero miles
>> at zero mph, but with an average speed of 5.5 mph; I'd like to see how
>> they did that math.  The error aligns with the beginning of the
>> "drive".  I also recall that the OVMS phone application configured the
>> current to 10 amps (other values were grayed out), even though I have
>> the car set to 24.  I was able to bump it back up to 24 through the VDS
>> for the charge.
>> {shrug} 
>> Fingers crossed that it was just something about the CAN messages that
>> confused the car, and that no damage was done.
>> Greg
>> Greg D. wrote:
>>> Hi folks,
>>> To the Roadster owners among us...  I just tried switching my 2.0
>>> Roadster from Standard to Range mode charging, and there was an unusual
>>> "pop", similar to the car or OpenEVSE contactors engaging, but louder,
>>> followed by all the fans going off and a "Power Train Service Required"
>>> error on the display.  Tapping away the message, the car started
>>> charging in Range mode as normal...  Odd, and rather unnerving, given
>>> that I'm heading out on a trip shortly.  I'll pull the logs when I return.
>>> This was my first experience using the OVMS system to control charging. 
>>> I don't want to try it again.
>>> Has anyone else tried doing this?
>>> Greg
>> _______________________________________________
>> OvmsDev mailing list
>> OvmsDev at lists.openvehicles.com
>> http://lists.openvehicles.com/mailman/listinfo/ovmsdev
> _______________________________________________
> OvmsDev mailing list
> OvmsDev at lists.openvehicles.com
> http://lists.openvehicles.com/mailman/listinfo/ovmsdev

More information about the OvmsDev mailing list