[Ovmsdev] Car firmware v1.2.7

Mark Webb-Johnson mark at webb-johnson.net
Sat Jun 9 21:17:42 HKT 2012

I'm using:

Product Version: MPLAB X IDE Beta7.02
Java: 1.6.0_31; Java HotSpot(TM) 64-Bit Server VM 20.6-b01-415
System: Mac OS X version 10.7.4 running on x86_64; MacRoman; en_US (mplab)

mcc18: v3.40

My mplink, on a clean-and-build gives:

/Applications/microchip/mplabc18/v3.40/bin/mplink    -p18f2680  -w    -z__MPLAB_BUILD=1  -u_CRUNTIME -l /Applications/microchip/mplabc18/v3.40/bin/../lib  -odist/TR_Experimental/production/OVMS.X.production.cof build/TR_Experimental/production/UARTIntC.o build/TR_Experimental/production/can_teslaroadster.o build/TR_Experimental/production/crypt_base64.o build/TR_Experimental/production/crypt_hmac.o build/TR_Experimental/production/crypt_md5.o build/TR_Experimental/production/crypt_rc4.o build/TR_Experimental/production/led.o build/TR_Experimental/production/net.o build/TR_Experimental/production/net_msg.o build/TR_Experimental/production/net_sms.o build/TR_Experimental/production/ovms.o build/TR_Experimental/production/params.o build/TR_Experimental/production/utils.o      
MPLINK 4.40, Linker
Device Database Version 1.3
Copyright (c) 1998-2011 Microchip Technology Inc.
Errors    : 0

I'm on a mac, running the beta mplabx (if it ain't broke, don't ...)

Are Tom and Piotr getting exactly the same error in the hmac module? Strange because that module hasn't changed since the beginning of OVMS.


On 9 Jun, 2012, at 1:49 AM, Tom Saxton wrote:

> I had the same problem trying to build last week. Mark gave me a list of
> things to check, then life happened and I just got back to it.
> I'm using MPLAB X v1.10 and mcc18 v3.40.
> I chose TR_Production for the build settings, confirmed that mcc18
> optimizations are set to "Enable all" and did a "Clean and Build" (not
> "Clean and Build for Debugging").
> I still get the linker error, same as before.
> I get the same result for the TR_Experimental build.
> Wondering if I had done something to mess up my sources, I deleted the
> entire OVMS project directory, did a fresh git clone, and repeated the
> steps. Same result.
>    Tom
> PS: You can copy from the build output window and paste into a text file.
> This yields a much smaller email attachment and it doesn't crop off the end
> of the build commands.
> on 6/8/12 10:07 AM, 911carrera4 wrote:
>> Hi guys
>> Unfortunately  I have a problem with the compilation of the firmaware files
>> 1.2.7. I'm using MPLAB X DIE 1.00
>> Please see enclosed picture.
>> I can't compile the project and also the use of the hex-file for flashing is
>> impossible.
>> Does this sound familiar to anyone?
>> The previously released firmware versions worked out fine.
>> Greetings, Piotr

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openvehicles.com/pipermail/ovmsdev/attachments/20120609/de89ee13/attachment.htm>

More information about the OvmsDev mailing list